verhuuradministratie bed en breakfast

In dit voorbeeld gaan we een klantenlijst en een prijslijst koppelen aan een boekingslijst waarin we boekingen verrichten voor een bed en breakfast. Ook bijkomende kosten worden in deze boekingslijst geplaatst. Met alleen het klantnummer invullen bovenin de boekingslijst krijg je de factuur. en door filteren op maandnummer krijg je een bezettingsoverzicht. Door op de klantenlijst een taalcode te plaatsen wordt de factuur automatisch in de gewenste taal gemaakt

Prijslijst

3 talige prijslijst. Op de klantenlijst vult U per klant de gewenste taalcode in. Bij het invullen van het klantennummer wordt de factuur in de gewenste taal aangemaakt

De 3 achterste kolommen zijn de taal kolommen. In cel B1 wordt de taalcode opgehaald als op de factuur het klantnummers is ingevuld. Bij de eerste kolom worden de prijzen opgehaald en de gewenste taal komt uit de 2e kolom die is weer afhankelijk van de taalcode in cel B1. uitleg hierover komt later op deze pagina.

klantenlijst.

waarom de nummering van de kolommen? Deze nummering wordt bv gebruikt op de factuur. Het klantnummer staat bv in kolom 1 Naam van de klant op de factuur staat in kolom2. De taalcode staat in kolom 15. uitleg hierover volgt nog.

boekingslijst.

Boekingslijst. D.m.v. klantennummer en IDnr van de prijslijst wordt de boekingslijst gevuld. In de kantlijn bij regel 13 ziet U een plusje, hiermee opent U de factuur. Tussen E en H zitten 2 reserve kolommen verborgen

Gebruikte formules: in kolom D vult U het klantennummer in. In kolom E staat de formule: =ALS($D14=””;””;VERT.ZOEKEN($D14;Klantenlijst!$A$3:$O$520;2;ONWAAR)) simpel gezegd staat hier als in cel D14 niets staat, moet er niets gebeuren. Anders moet er verticaal gezocht worden het nummer uit D14 op de klantenlijst die begint in cel A3 en eindigt in cel O520. naar de omschrijving in de 2e kolom behorende bij het nummer uit D14.

In kolom kolom I vult bij verblijfskosten aantal personen in. Het aantal dagen wordt automatisch uitgerekend. Als kolom C leeg is, wordt kolom L altijd een 1. Als er een einddatum is ingevuld is de formule C14-B14. Bij een lege kolom C is het altijd een bijkomende iets, dat kan bv fietshuur per dag zijn.

Met het invullen van het Idnr van de prijslijst wordt weer de formule verticaal zoeken gebruikt: =ALS($H14=””;””;VERT.ZOEKEN($H14;Prijslijst!$B$4:$G$325;2;ONWAAR)) de omschrijving vindt u in kolom 2 van de prijslijst. De prijs vindt U in de 3e kolom. Kijk even op het bovenste plaatje kolom B is de eerste kolom, C de 2e kolom en B de 3e kolom. Het invullen van deze lijst doet U op willekeurige volgorde van binnenkomst.

Kop van de factuur.

In bovenstaand plaatje hebben we de kop (van de factuur) van de database opengemaakt door op het plusje te klikken in de kantlijn bij regelnummer 13. Het plusje is een min geworden als je daar weer op klikt sluit de kop weer. Dit openen doe je als je een factuur wilt aanmaken. In B3 vul je het klantnummer in, de klantgegevens worden nu automatisch van de klantlijst afgehaald en in A 5 komt de taal code. Als je nu de database filtert op klantnummer krijg je de complete factuur.

factuur in het nederlands, duits en Engels

excel tabel maken:

De boekingslijst moeten we nog omzetten naar een tabel/database. Hoe: U selecteert het hele bestandje inclusief de kop van de database. De kop van de factuur laat U zitten. U klikt in cel B13 selecteer de hele regel t/m cel O13 en dan trekt U deze selectie door tot de onderste regel. Ga bovenin het lint van Excel naar INVOEGEN en klik op het icoon tabel en vink nog even aan dat de database een kop heeft. Een voorbeeld van deze instelling vindt U op mijn webpagina: https://excel-spreadsheet.nl/excel-tabellen-een-uitleg/

Nadat U van de boekingslijst een tabel heeft gemaakt, krijgt U er een heleboel mogelijkheden bij. bv automatische kleur opmaak, U hoeft maat op een kleur te klikken en eigen opmaak kan natuurlijk ook. In de kolom koppen ziet U nu kleine grijze blokjes dit zijn de filters.

Gebruikte formules:

1- Voor opzoeken van Naam en omschrijving uit de prijslijst op de boekingslijst is de formule verticaal zoeken gebruikt. Dit heb ik bovenaan uitgelegd. Meer info op mijn webpagina: https://excel-spreadsheet.nl/verticaal-of-horizontaal-zoeken-in-excel/

2- Totaal bedrag op de factuur. b.v. op de eerste factuur met klantnummer 101 en een totaalbedrag van 370 euro. Hiervoor wordt de formule SOM.ALS gebruikt. =SOM.ALS(D14:D2354;D2356;O14:O2354) D14-D2354 is de kolom waar de klantennummers staan. In Cel D2356 staat het klantnummer waarvan de bedragen moeten worden opgezocht. in kolom O14-O2354 Meer info over deze formule vindt U op mijn webpagina: https://excel-spreadsheet.nl/som-als-en-sommen-als/

3- Hoe krijgen we de factuur in de juiste taal: Zodra U een klantnummer op de factuur invult (in cel B3) wordt de taalcode voor U opgezocht op de klantenlijst. In kolom 15 van de klantenlijst vindt U de taalcode. In cel A5 wordt de taalcode voor U opgehaald met de formule: .=ALS($B$3=””;””;VERT.ZOEKEN($B$3;Klantenlijst!$A$3:$O$520;15;ONWAAR)) Hier staat als in B3 niets staat, dan niets anders moet er gezocht worden naar de inhoud van de 15 e kolom behorende bij het nummer wat in A3 staat.

4- In cel B1 op de prijslijst staat de formule =Boekingslijst A5. Met deze code wordt de 2e brede kolom de taal opgehaald. De formule die daar staat is:=ALS($B$1=”N”;K4;ALS($B$1=”D”;M4;ALS($B$1=”E”;O4;K4))) Met de hier genoemde taalcode wordt de omschrijving weggehaald uit de kolommen K – M of O

Laatste opmerkingen: Dit rekenmodel heb ik enige tijd terug voor iemand ontwikkeld en is inmiddels een aantal malen in gebruik. Als ik een update zou maken. Zou ik nog een kolom met weeknummer tussenvoegen om per week een overzicht te krijgen. En ik zou een standaard basis kolom bijmaken met een originele nummering van 1 t/m de laatste regel (met de functie doorvoeren reeks) Als je dan een maandoverzicht hebt uitgefilterd en je zou de datums nog op volgorde sorteren heb je een mooier overzicht en compleet terug zetten naar originele nummering doe je dan met de basis kolom.

Dit rekenmodel kunt U ook bekijken op mijn webpagina: https://excel-spreadsheet.nl/bb-verhuuradministratie/